advertisement
advertisement

Nevro problems

I had a Nevro stimulator placed May 2018.  It was great and then 4 months in, the leads slipped.   Had a revision surgery in Oct 2018.   Each surgery the doctor said I had so much scar tissue it was hard to get the leads placed.   After the revision surgery I have been reprogrammed numerous times and with no help.  Seems to help for a few days and then my pain comes back.   I have had it turned off for at least a month and I meet with my rep today and gonna ask for removal.   I have had 3 fusions from S1-L2.   Has anyone had a stimulator work and then just stop working?   They did xrays and they said the leads have migrated to the left but have no come down. 

advertisement

Comments

  • memerainboltmemerainbolt IndianaPosts: 3,403

    Byrd

    Mine worked great in the trial. But once it was implanted, nothing but problems. I had it and the leads removed. Read through the forum, there are other discussions on this topic that may help you out.

    Good luck today and let us know what your rep says.

  • I was reprogrammed today again.  I am going tomorrow and see if the leads have moved again.  

  • advertisement
  • Byrd, I also had a bad experience with the same SCS. I had it for 5 months and it just made my pain worse. It works well for some and I don't regret giving it a try. Sadly the more revisions, the more scar tissue. I had paddles so my leads never moved but I still have pain in the laminectomy site and a neuroma in the battery site. Wish you the best and keep us posted. 

  • Are you saying you aren't feeling any stimulation and the device has stopped working? Or are you saying that you have stimulation, but no therapeutic benefit?

  • With the Nevro you don't feel the stimulation.   I am having no relief with it as of now.   I was suppose to have x rays Friday to see if the leads have moved again but the cancelled.

  • advertisement
advertisement
Sign In or Join Us to comment.